Whenever you store a value that has a unit in a variable, config option or CLI switch, include the unit in the name. So:
maxRequestSize
=>maxRequestSizeBytes
elapsedTime
=>elapsedSeconds
cacheSize
=>cacheSizeMB
chargingTime
=>chargingTimeHours
fileSizeLimit
=>fileSizeLimitGB
temperatureThreshold
=>temperatureThresholdCelsius
diskSpace
=>diskSpaceTerabytes
flightAltitude
=>flightAltitudeFeet
monitorRefreshRate
=>monitorRefreshRateHz
serverResponseTimeout
=>serverResponseTimeoutMs
connectionSpeed
=>connectionSpeedMbps
EDIT: I know it’s better to use types to represent units. Please don’t write yet another comment about it. You can find my response to that point here: https://programming.dev/comment/219329
Variables, meh. As long as the code is clear, I don’t mind too much about naming. For config options? Absolutely.